Platform Disruption

Incident Report for CentralReach

Resolved

Platform performance has returned to expected levels and has been fully restored.
Posted May 04, 2026 - 19:09 EDT

Monitoring

Platform performance has returned to expected levels. We are monitoring to confirm the incident has been fully resolved and will provide a final update shortly.
Posted May 04, 2026 - 18:27 EDT

Update

Our teams are continuing to work to restore platform performance to expected levels. Experience has improved but some users may continue to experience slowness when loading some screens.
Posted May 04, 2026 - 18:08 EDT

Investigating

We are experiencing platform disruption that is preventing users from logging into CentralReach. Our teams are investigating and working to restore access as quickly as possible.
Posted May 04, 2026 - 17:47 EDT
This incident affected: CentralReach Platform.